문맥 (context)
사회의 급속한 정보화 물결을 유도하고 있는 인터넷은 그 사용 범위가 거의 무제한으로 확장되고 있으며 기존의 음성 통신을 위한 전화 서비스조차도 인터넷을 기반으로 변경되고 있다.
급증하는 인터넷 사용자 및 유비쿼터스 센서 네트워크(USN, Ubiquitous Sensor Network) 등 다양하고 광범위한 분야에서의 인터넷의 응용은 그만큼 많은 수의 인터넷 프로토콜(IP, Internet Protocol) 주소를 필요로 하며, 특히 음성 및 화상 통신 등에 인터넷을 이용할 경우 단대단 통신을 위해서 NAT(Network Address Translation) 등을 이용한 사설 IP가 아닌 고유의 IP 주소가 필요하다.
그러나, 모든 유무선 통신 단말이 IP로 통합되는 전(全)-IP(All-IP)망에서, 대량의 단말에 공인 IP 주소를 할당하기 위해 그 용량은 거의 소진되고 있다. 따라서, 이러한 문제를 해결하기 위해 인터넷 엔지니어링 태스크 포스(IETF, Internet Engineering Task Force)는 인터넷 프로토콜 버전 6(IPv6, Internet Protocol Version 6)(IETF RFC3513)를 차세대 인터넷을 위한 새 주소체계로 표준화하였다. 그러므로, 인터넷 프로토콜 버전 4(IPv4, Internet Protocol version 4) 주소를 대체하여 차세대 인터넷 주소 표준인 IPv6로의 전환은 필수적인 일로 예견되고 있다.
차세대 인터넷의 주소체계인 IPv6는 사용 가능한 IP 주소의 수를 증가시키는 것뿐만 아니라 자동 주소 설정 및 규격화된 옵션 헤더 등의 신기술이 포함되어 있어 기존의 IPv4 체계에서 해결이 어려웠던 인터넷의 여러 문제점들을 해결할 수 있을 것으로 예상된다.
특히, 128비트로 구성된 IPv6는 IPv4와 달리 거의 무한한 IP 주소 대역을 갖고 있으므로 풍부한 수의 고유 IP 주소를 개인 또는 단말들에게 할당할 수 있으며, 이를 이용하여 IPv6 주소를 개인의 ID로 사용할 수 있어 IP 주소에 기반한 개인화 서비스가 가능하다.
또한, IPv6는 주소 자동 설정 등의 기능이 지원되므로 단말의 이동이 빈번히 발생할 수 있는 무선 인터넷에 대하여 단말의 이동성 지원에 장점을 보유하고 있다. 따라서, IPv6는 무선 인터넷에 더욱 적합한 주소 체계라 볼 수 있다.
현재 무선 인터넷은 유선 인터넷에 이어 인터넷의 차세대 인프라로서 활발히 확장되어 가고 있으며, 와이파이(WiFi, Wireless-Fidelity)(IEEE 802.11) 표준에 기반을 둔 무선 랜(Wireless LAN)이나 3 세대(generation)의 일종인 광대역 부호 분할 다중 접속(WCDMA, Wideband code division multiple access) 및 와이브로(WiBro, Wireless Broadband)(IEEE 802.16e) 등의 무선 접속망이 서비스되고 있다.
무선 인터넷은 유선 인터넷과 달리 단말 장비의 이동이 자유로워 그 응용 범위가 매우 다양하기 때문에 그 활용이 점차 대중화되고 있으며, 유선 통신 인프라가 IP 기반으로 통합되어 가고 있다.
하지만 각 표준마다 별도의 방식을 채택하고 있기 때문에, 다양한 종류의 무선 인터넷 접속망 사이에서 인터넷 단말이 이동하는 경우, 끊김 없는 접속이 계속 유지되는 것은 용이하지 않다.
따라서, 다양한 종류의 무선 인터넷 접속망간의 자유로운 이동은 유무선이 통합된 진정한 전-IP(All-IP) 망 실현을 위해 넘어야 할 중요한 기술적 과제로 인식되고 있다.
다양한 이(異)기종 유무선망 간 단말의 이동을 위해, 모바일 IPv4(MIPv4, Mobile IPv4)(IETF RFC3344)와 모바일 IPv6(MIPv6, Mobile IPv6)(IETF RFC3773) 등으로 대표되는 레이어(layer) 3 계층에서의 프로토콜들이 등장하였다. 그러나, MIPv4 및 MIPv6 등에서 인터넷 단말은 이동할 때마다 위치 등록 등의 중요한 역할을 직접 수행해야 하는 구조이며, 이러한 구조는 실제 서비스에 적합하지 않기 때문에 그 적용이 활발히 이루어지지 않고 있다.
따라서 IP 계층에서의 무선 단말 이동성 지원은 실제 망에서 거의 적용되지 않으며, WCDMA, WiBro 등 현재의 무선 인터넷 망에서 이동성 (Mobility) 지원은 대부분 레이어 2 계층을 중심으로 각 방식에 따라 독립적으로 이루어지고 있다.
이를 극복하고자 단말의 역할이 최소화 되는 프록시 모바일 IPv6(PMIPv6, Proxy Mobile IPv6)(IETF draft-ietf-netlmm-proxymip6-06.txt) 등의 망 기반 단말 이동성 지원 기술 등이 최근 등장하고 있다.
망 기반 단말 이동성 지원 기술은, 이동 단말(MN, Mobile Node)이 이동한 사실을 무선 접속망의 장치인 MAG(Media Access Gateway)(또는 프록시 모바일 에이전트(PMA, Proxy Mobile Agent)라고도 불림)가 감지하여 단말을 대신하여 단말의 해당 LMA(Local Mobility Anchor)(MIPv6의 홈 에이전트(HA, Home Agent) 기능 포함)에게 등록 요청을 대행하는 구조로서, 단말이 IP 이동성을 위한 어떠한 역할을 하지 않고 이동하면서 단말의 HoA(Home Address)를 유지할 수 있도록 지원하는 구조를 택하고 있다.
따라서, PMIPv6에서 이동 단말은 자신의 HoA 주소를 계속 유지할 수 있고, 인터넷 상 통신 상대 단말(CN, Correspondent Node)도 이동 단말(MN)의 HoA로 계속 통신을 할 수 있다. 그러므로, 이동 단말의 IPv6 주소를 이용하여 사용자 인증 및 차별 서비스 등을 제공하고자 하는 IPv6 개인화 기반 서비스에 대하여 PMIPv6가 MIPv6보다 적합하다.
그러나, 기존의 IPv4 기반 무선 인터넷 망의 장치들을 PMIPv6(Proxy Mobile IPv6) 망 기반 이동성 지원 기술이 적용되도록 장비들을 대체 또는 개체하는 것은 상당한 기술적, 경제적 어려움이 뒤따른다.
또한, 향후 새로운 IP 이동성 지원 기법을 무선 인터넷 망에 도입하고자 할 때마다 무선 인터넷 망의 장비들을 새로이 대체 또는 개체해야 하는 문제가 발생한다.
종래의 한국등록특허 제0612007호 및 한국공개특허 제2006-0091555호에서는 IPv4 기반 인터넷 망과IPv6 기반 인터넷 망 사이의 전환 및 연동을 위한 장치 및 방법에 대하여 개시하고 있으나, 모바일 IPv4 인프라를 기반으로 프록시 모바일 IPv6의 이동성 지원을 제공하는 기술에 대해서는 해법을 제공하지 못하고 있다.
지시문 (instruction)
주어진 원문을 읽고 필요한 정보를 파악하여, 원문에 근거해 질문에 답하라.
질문 (question)
IPv6 개인화 기반 서비스에서 PMIPv6가 MIPv6보다 적합하게 기능하기 위한 조건은 무엇인가?
추론 과정 (compact_reasoning)
-
1과제 해석
task_interpretationPMIPv6가 MIPv6보다 IPv6 개인화 기반 서비스에 더 적합한 이유와 그 전제 조건을 파악한다.
-
2정보 추출
information_extractionMIPv6의 한계와 PMIPv6의 특징을 추출한다.
- MIPv4 및 MIPv6 등에서 인터넷 단말은 이동할 때마다 위치 등록 등의 중요한 역할을 직접 수행해야 하는 구조이며
- 이동 단말(MN, Mobile Node)이 이동한 사실을 무선 접속망의 장치인 MAG(Media Access Gateway)(또는 프록시 모바일 에이전트(PMA, Proxy Mobile Agent)라고도 불림)가 감지하여 단말을 대신하여 단말의 해당 LMA(Local Mobility Anchor)(MIPv6의 홈 에이전트(HA, Home Agent) 기능 포함)에게 등록 요청을 대행하는 구조
-
3근거 선택
evidence_selectionPMIPv6가 개인화 서비스에 적합한 핵심 근거인 '단말의 역할 최소화'와 'HoA 유지'를 선별한다.
- 단말이 IP 이동성을 위한 어떠한 역할을 하지 않고 이동하면서 단말의 HoA(Home Address)를 유지할 수 있도록 지원하는 구조를 택하고 있다.
- 이동 단말의 IPv6 주소를 이용하여 사용자 인증 및 차별 서비스 등을 제공하고자 하는 IPv6 개인화 기반 서비스에 대하여 PMIPv6가 MIPv6보다 적합하다.
-
4논리 통합
logical_integrationMIPv6는 단말이 직접 위치 등록을 해야 하므로 부적합하지만, PMIPv6는 단말 대신 MAG가 등록을 대행하여 단말이 HoA를 유지할 수 있으므로 개인화 서비스에 적합함을 연결한다.
- 단말이 IP 이동성을 위한 어떠한 역할을 하지 않고 이동하면서 단말의 HoA(Home Address)를 유지할 수 있도록 지원
-
5결론 도출
conclusion_formulation단말이 직접 역할을 수행하지 않고 HoA를 유지할 수 있는 구조적 조건이 갖춰질 때 적합하다.
- 단말이 IP 이동성을 위한 어떠한 역할을 하지 않고 이동하면서 단말의 HoA(Home Address)를 유지할 수 있도록 지원하는 구조
-
6답변 생성
answer_generation질문에 대해 PMIPv6의 작동 방식과 그로 인한 이점을 포함하여 답변을 작성한다.
- 단말이 IP 이동성을 위한 어떠한 역할을 하지 않고 이동하면서 단말의 HoA(Home Address)를 유지할 수 있도록 지원
최종 답변 (final_answer)
이동 단말이 IP 이동성을 위한 어떠한 역할을 직접 수행하지 않고도 이동하면서 자신의 HoA(Home Address)를 계속 유지할 수 있는 구조를 갖추어야 한다. 이는 MAG(Media Access Gateway)가 단말을 대신하여 LMA에게 등록 요청을 대행함으로써 가능해진다.
핵심 해석 (core_interpretation)
PMIPv6가 개인화 서비스에 적합한 이유는 망 기반으로 단말의 HoA를 유지하면서 이동성을 지원하기 때문이다.